summaryrefslogtreecommitdiff
path: root/alacritty_terminal/Cargo.toml
diff options
context:
space:
mode:
authorChristian Duerr <chrisduerr@users.noreply.github.com>2019-04-28 20:21:39 +0000
committerGitHub <noreply@github.com>2019-04-28 20:21:39 +0000
commit9e89aaa477369b20a06f4b9f636d7fd543c4c985 (patch)
tree81deb1b250541a3c8fe7b6f9274f5a87f265a314 /alacritty_terminal/Cargo.toml
parent37b66a7cd2e53fae93e3c2c8bc3ddbd9cbe140d2 (diff)
downloadalacritty-9e89aaa477369b20a06f4b9f636d7fd543c4c985.tar.gz
alacritty-9e89aaa477369b20a06f4b9f636d7fd543c4c985.zip
Switch from copypasta to rust-clipboard
This switches our own `copypasta` crate with the more standardized `clipboard` library, which allows us to get rid of the `xclip` dependency on X11. Additionally, this lays the foundation for native Wayland clipboard support once the clipboard crate is updated (or a fork is created). Fixes #5.
Diffstat (limited to 'alacritty_terminal/Cargo.toml')
-rw-r--r--alacritty_terminal/Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/alacritty_terminal/Cargo.toml b/alacritty_terminal/Cargo.toml
index 8d9ca639..18164fb9 100644
--- a/alacritty_terminal/Cargo.toml
+++ b/alacritty_terminal/Cargo.toml
@@ -23,7 +23,6 @@ serde_yaml = "0.8"
vte = "0.3"
mio = "0.6"
mio-extras = "2"
-copypasta = { path = "../copypasta" }
xdg = "2"
log = "0.4"
clap = "2"
@@ -35,6 +34,7 @@ static_assertions = "0.3.0"
terminfo = "0.6.1"
url = "1.7.1"
crossbeam-channel = "0.3.8"
+clipboard = { git = "https://github.com/chrisduerr/rust-clipboard" }
[target.'cfg(unix)'.dependencies]
nix = "0.13"