summaryrefslogtreecommitdiff
path: root/alacritty_terminal/Cargo.toml
diff options
context:
space:
mode:
authorKirill Chibisov <contact@kchibisov.com>2023-10-11 03:23:19 +0400
committerGitHub <noreply@github.com>2023-10-11 03:23:19 +0400
commitb4130ddf24d9612cce4cb043e9b15acc086369a1 (patch)
tree6df4d7ad8dc2b4b3124945b140814c3a90dcadce /alacritty_terminal/Cargo.toml
parente1859e80f6196da6f52aacf8829c039378e13275 (diff)
downloadalacritty-b4130ddf24d9612cce4cb043e9b15acc086369a1.tar.gz
alacritty-b4130ddf24d9612cce4cb043e9b15acc086369a1.zip
Use openpty-rustix instead of nix
Follow upstream libraries and use rustix to reduce the amount of dependencies in the future. Co-authored-by: Christian Duerr <contact@christianduerr.com>
Diffstat (limited to 'alacritty_terminal/Cargo.toml')
-rw-r--r--alacritty_terminal/Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/alacritty_terminal/Cargo.toml b/alacritty_terminal/Cargo.toml
index e6712de3..a0bdac49 100644
--- a/alacritty_terminal/Cargo.toml
+++ b/alacritty_terminal/Cargo.toml
@@ -33,7 +33,7 @@ unicode-width = "0.1"
vte = { version = "0.12.0", default-features = false, features = ["ansi", "serde"] }
[target.'cfg(unix)'.dependencies]
-nix = { version = "0.27.1", default-features = false, features = ["term"] }
+rustix-openpty = "0.1.1"
signal-hook = "0.3.10"
[target.'cfg(windows)'.dependencies]