aboutsummaryrefslogtreecommitdiff
path: root/alacritty_terminal/Cargo.toml
diff options
context:
space:
mode:
authorKirill Chibisov <contact@kchibisov.com>2022-03-16 19:27:55 +0300
committerGitHub <noreply@github.com>2022-03-16 19:27:55 +0300
commitf4bdf5fb36fdf3b329be8253da39050abe7238a5 (patch)
tree9b49a78b15fdd73850a7bfc279e3986af2b59683 /alacritty_terminal/Cargo.toml
parent589c1e9c6b8830625162af14a9a7aee32c7aade0 (diff)
downloadalacritty-f4bdf5fb36fdf3b329be8253da39050abe7238a5.tar.gz
alacritty-f4bdf5fb36fdf3b329be8253da39050abe7238a5.zip
Add colored underline support
This commit adds support for colored underline and refines the dynamic extra storage. The extra storage now is using `Arc` making cloning it way faster compared to `Box` approach which scales really well when it comes to cloning in `Term::write_at_cursor`, since cloning `Arc` is constant time. Fixes #4142.
Diffstat (limited to 'alacritty_terminal/Cargo.toml')
-rw-r--r--alacritty_terminal/Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/alacritty_terminal/Cargo.toml b/alacritty_terminal/Cargo.toml
index 269b110a..33cccf3d 100644
--- a/alacritty_terminal/Cargo.toml
+++ b/alacritty_terminal/Cargo.toml
@@ -17,7 +17,7 @@ version = "0.1.0"
libc = "0.2"
bitflags = "1"
parking_lot = "0.11.0"
-serde = { version = "1", features = ["derive"] }
+serde = { version = "1", features = ["derive", "rc"] }
serde_yaml = "0.8"
vte = { version = "0.10.0", default-features = false }
mio = "0.6.20"