summaryrefslogtreecommitdiff
path: root/alacritty_terminal/Cargo.toml
diff options
context:
space:
mode:
authorChristian Duerr <contact@christianduerr.com>2021-01-01 05:07:39 +0000
committerGitHub <noreply@github.com>2021-01-01 05:07:39 +0000
commit8ed72cc065255007a7f0687e3b8a540e8c6202c6 (patch)
tree97be52ae4c288fcfeb849d1f97f7a5efc9c2dab1 /alacritty_terminal/Cargo.toml
parent1723e30d25f0c6068f9532448b016a89aa491a95 (diff)
downloadalacritty-8ed72cc065255007a7f0687e3b8a540e8c6202c6.tar.gz
alacritty-8ed72cc065255007a7f0687e3b8a540e8c6202c6.zip
Remove Windows WinPTY backend
Diffstat (limited to 'alacritty_terminal/Cargo.toml')
-rw-r--r--alacritty_terminal/Cargo.toml5
1 files changed, 0 insertions, 5 deletions
diff --git a/alacritty_terminal/Cargo.toml b/alacritty_terminal/Cargo.toml
index b859185c..5bc144b2 100644
--- a/alacritty_terminal/Cargo.toml
+++ b/alacritty_terminal/Cargo.toml
@@ -32,7 +32,6 @@ nix = "0.18.0"
signal-hook = { version = "0.1", features = ["mio-support"] }
[target.'cfg(windows)'.dependencies]
-mio-named-pipes = "0.1"
miow = "0.3"
winapi = { version = "0.3.7", features = [
"impl-default", "basetsd", "libloaderapi", "minwindef", "ntdef", "processthreadsapi", "winbase",
@@ -40,10 +39,6 @@ winapi = { version = "0.3.7", features = [
]}
mio-anonymous-pipes = "0.1"
-# Winpty crate supports only MSVC.
-[target.'cfg(all(target_os="windows", target_env="msvc"))'.dependencies]
-winpty = { version = "0.2.0", optional = true }
-
[features]
default = []
bench = []