aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorChristian Dürr <contact@christianduerr.com>2017-12-28 21:36:30 +0100
committerJoe Wilm <jwilm@users.noreply.github.com>2018-01-03 11:15:57 -0800
commitb83a26ffe097ba9bf80b2801ba27737f6ccd90be (patch)
tree6c19f20fcb53b29f0599a55d2556b8c794a9fcad /Cargo.toml
parent20aa45c8781f1954de90bb23070454a9581e6969 (diff)
downloadalacritty-b83a26ffe097ba9bf80b2801ba27737f6ccd90be.tar.gz
alacritty-b83a26ffe097ba9bf80b2801ba27737f6ccd90be.zip
Enable shift+select in mouse mode
When an application takes control over the mouse, it usually disables selection completely. However the common way to still make selection possible is by allowing selection while the shift key is held down. This feature is implemented here by making use of the new `modifiers` field on mouse events with glutin/winit. This fixes jwilm/alacritty#146.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index c794b4bb..eee109d8 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -33,7 +33,7 @@ clap = "2"
fnv = "1"
unicode-width = "0.1"
arraydeque = "0.2"
-glutin = "0.11"
+glutin = "0.12"
clippy = { version = "*", optional = true }
env_logger = "0.4"
base64 = "0.9.0"