diff options
author | Joe Wilm <joe@jwilm.com> | 2016-08-29 19:23:04 -0700 |
---|---|---|
committer | Joe Wilm <joe@jwilm.com> | 2016-08-29 19:23:04 -0700 |
commit | fd755831f2cae4e36206f28b06b205a7a53063e1 (patch) | |
tree | da5ea1a7e345cd141c21adfa8c0a8f104b004114 /Cargo.toml | |
parent | 3c5d46c8518fb6a1a6e1679ba3a2cc8815f37d3c (diff) | |
download | alacritty-fd755831f2cae4e36206f28b06b205a7a53063e1.tar.gz alacritty-fd755831f2cae4e36206f28b06b205a7a53063e1.zip |
Separate input handling from rendering
To minimize rendering, the input must be handled in a separate thread.
To see, why, consider the optimal rendering solution: renders are only
necessary when the pty has data that changes the terminal state, OR
there is a window event which changes the graphics state. When not
drawing, the render thread is to remain parked at a condition variable,
and it's not possible to handle input while parked! Thus, we need a
separate thread.
In addition to adding the separate thread, each subsystem thread is now
spawned in a separate function to (hopefully) improve readability.
Diffstat (limited to 'Cargo.toml')
-rw-r--r-- | Cargo.toml | 4 |
1 files changed, 2 insertions, 2 deletions
@@ -13,7 +13,7 @@ notify = "2.6" bitflags = "*" font = { path = "./font" } errno = "0.1.6" -parking_lot = "0.2.6" +parking_lot = "0.3.1" serde = "0.7" serde_yaml = "0.2" serde_macros = "0.7" @@ -23,4 +23,4 @@ gl_generator = "0.5" [dependencies.glutin] git = "https://github.com/jwilm/glutin" -rev = "22cc23997389bedd948a3ddc3833279ed308a673" +rev = "45092a8e2f6706a7b2c613ff212341754e346c9c" |