diff options
author | Joe Wilm <joe@jwilm.com> | 2016-05-20 21:36:28 -0700 |
---|---|---|
committer | Joe Wilm <joe@jwilm.com> | 2016-05-20 21:36:28 -0700 |
commit | c70acbac0b721ea2f1b1442898c22aee0f360ef2 (patch) | |
tree | a78722cbabb59c59e7dacc02a4c4d05405839dea /Cargo.toml | |
parent | e794bc11b962adef4d6fbbaeb85344cb138376da (diff) | |
download | alacritty-c70acbac0b721ea2f1b1442898c22aee0f360ef2.tar.gz alacritty-c70acbac0b721ea2f1b1442898c22aee0f360ef2.zip |
Correct sub-pixel font rendering with OpenGL
Uses the GL_ARB_blend_func_extended to get single-pass, per-channel
alpha blending. gl_generator is now used instead of gl to enable the
extension.
The background color is removed since that presumably needs to run in a
separate pass.
Diffstat (limited to 'Cargo.toml')
-rw-r--r-- | Cargo.toml | 6 |
1 files changed, 5 insertions, 1 deletions
@@ -4,14 +4,18 @@ version = "0.1.0" authors = ["Joe Wilm <joe@jwilm.com>"] license = "Apache-2.0" +build = "build.rs" + [dependencies] servo-fontconfig = { git = "https://github.com/jwilm/rust-fontconfig" } freetype-rs = "0.5.0" libc = "*" -gl = "*" cgmath = "0.7" euclid = "0.6" +[build-dependencies] +gl_generator = "0.5" + [dependencies.glutin] git = "https://github.com/jwilm/glutin" rev = "c95e6973ace3cbf321123a64588b27f032675be9" |