aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorJoe Wilm <joe@jwilm.com>2016-09-23 10:12:11 -0700
committerJoe Wilm <joe@jwilm.com>2016-09-23 10:12:11 -0700
commitbe09467d48a5b7644411c2a09d948ee89509894e (patch)
treeea49bab6e759d617c45ea0c8ed10a6dda918e185 /Cargo.toml
parentcbeec3df5a19487a9dfaf3b285ab6722e69fee54 (diff)
downloadalacritty-be09467d48a5b7644411c2a09d948ee89509894e.tar.gz
alacritty-be09467d48a5b7644411c2a09d948ee89509894e.zip
Fix some compiler warnings
Also enables debug symbols in release profile by default. Until Alacritty ships, there's going to be lots of perf analysis which needs debug symbols. The PriorityMutex low priority method was never used. Now it's just a fair mutex.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml3
1 files changed, 3 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index c855e255..a8067ccb 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -25,3 +25,6 @@ gl_generator = "0.5"
[dependencies.glutin]
git = "https://github.com/jwilm/glutin"
rev = "16ed800f68022a37203434bd3b542ff5400c1403"
+
+[profile.release]
+debug = true