aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorJoe Wilm <joe@jwilm.com>2016-08-31 21:16:17 -0700
committerJoe Wilm <joe@jwilm.com>2016-08-31 21:16:17 -0700
commit0517f376be3054ab736006dcfc24b404dcd8626c (patch)
tree6c979c71585544f96c8c27023a7dd14d9d5018af /Cargo.toml
parent0a94ccfccadfb4d560daa0c15763edb9be4c3040 (diff)
downloadalacritty-0517f376be3054ab736006dcfc24b404dcd8626c.tar.gz
alacritty-0517f376be3054ab736006dcfc24b404dcd8626c.zip
Eliminate extra renders
Currently has a bug where screen is blank at startup. That aside, Alacritty uses basically 0 CPU now. The input thread is still separate from the render thread, but, given the ability to wake the event loop, it may be possible to merge them again. I'm not sure if that's actually desirable. Performance is seemingly unchanged.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index d556a26c..9e8f8b81 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -13,7 +13,7 @@ notify = "2.6"
bitflags = "*"
font = { path = "./font" }
errno = "0.1.6"
-parking_lot = "0.3.1"
+parking_lot = { version = "0.3.1", features = ["nightly"] }
serde = "0.8"
serde_yaml = "0.4"
serde_macros = "0.8"