aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorSteven Fackler <sfackler@palantir.com>2017-01-21 10:11:55 +0000
committerJoe Wilm <jwilm@users.noreply.github.com>2017-01-23 08:59:54 -0800
commit41f99dc4c0860155003120e9eabfe8c4a6ff770a (patch)
tree5866e98f71dc2d722eaf7917591d40c316d0eabc /Cargo.toml
parent62294771905917087c484bfc57e4f6ca547d89ba (diff)
downloadalacritty-41f99dc4c0860155003120e9eabfe8c4a6ff770a.tar.gz
alacritty-41f99dc4c0860155003120e9eabfe8c4a6ff770a.zip
Dynamically generate test harness
This uses the rustc-test crate, a copy of the standard test crate, to dynamically create tests for each reference test. No need to remember to update the macro, just add the directory to ref!
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml6
1 files changed, 6 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index dc335150..02b0e95f 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -10,6 +10,10 @@ doc = false
path = "src/main.rs"
name = "alacritty"
+[[test]]
+name = "ref"
+harness = false
+
[dependencies]
libc = "*"
cgmath = "0.7"
@@ -44,6 +48,8 @@ gl_generator = "0.5"
git = "https://github.com/jwilm/glutin"
rev = "af7fe340bd4a2af53ea521defcb4f377cdc588cf"
+[dev-dependencies]
+rustc-test = "0.1"
[profile.release]
lto = true