aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorJoe Wilm <joe@jwilm.com>2016-06-04 15:30:17 -0700
committerJoe Wilm <joe@jwilm.com>2016-06-04 15:30:17 -0700
commit2f058bd053f52307bdbf3709209418ac26871678 (patch)
tree0609a8a3c1976d0e0bdaeede352a55d9c14cb13f /Cargo.toml
parentf944b517fa8bea6eae62eb25fbabe1308d16ed55 (diff)
downloadalacritty-2f058bd053f52307bdbf3709209418ac26871678.tar.gz
alacritty-2f058bd053f52307bdbf3709209418ac26871678.zip
Optimize rendering
This moves some logic that was previously being done per-character into the vertex shader. At this time, we've traded CPU computation for additional gl::Uniform2f calls. This is only a marginal improvement. However, this patch positions the renderer well for instanced drawing, and that will be a huge performance win.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index de8c09cc..b658930e 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -3,7 +3,7 @@ name = "alacritty"
version = "0.1.0"
authors = ["Joe Wilm <joe@jwilm.com>"]
license = "Apache-2.0"
-
+exclude = ["res/*"]
build = "build.rs"
[dependencies]