aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Eklöf <daniel@ekloef.se>2018-09-24 21:06:12 +0200
committerChristian Duerr <chrisduerr@users.noreply.github.com>2018-09-24 19:06:12 +0000
commitec3a80427b717bb13d56c3031f4195bdae9c011a (patch)
tree85f9119f88c2dfe56d8839150fc136623e14c624 /Cargo.toml
parent3d7e88e8a975f40996aaa71d951842db6f2fccbb (diff)
downloadalacritty-ec3a80427b717bb13d56c3031f4195bdae9c011a.tar.gz
alacritty-ec3a80427b717bb13d56c3031f4195bdae9c011a.zip
Add standalone terminfo definition
This replaces the current definitions, which depend on the system's 'xterm-256color' terminfo definition with the `alacritty` and `alacritty-direct` definitions. The new definitions are completely standalone. The default `TERM` value has been changed to be dynamically set based on the definitions installed on the system. Alacritty will try to use the `alacritty` definition first and fall back to `xterm-256color` if the `alacritty` definition is not present.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 8adf3ef3..6c54c0ac 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -39,6 +39,7 @@ glutin = "0.16"
env_logger = "0.5"
base64 = "0.9.0"
static_assertions = "0.2.5"
+terminfo = "0.6.1"
[target.'cfg(any(target_os = "linux", target_os = "freebsd", target_os="dragonfly", target_os="openbsd"))'.dependencies]
x11-dl = "2"