aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorVictor Berger <vberger@users.noreply.github.com>2017-10-06 17:47:51 +0200
committerJoe Wilm <jwilm@users.noreply.github.com>2017-10-06 08:47:51 -0700
commite17d38167e174a2cf664e430fe968ec6492e1f08 (patch)
treec74e31418463a17f6d153f55067d017d5d66ae06 /Cargo.toml
parent934c205a46a855ba66513d8cde4e8bd923b44239 (diff)
downloadalacritty-e17d38167e174a2cf664e430fe968ec6492e1f08.tar.gz
alacritty-e17d38167e174a2cf664e430fe968ec6492e1f08.zip
Update glutin & fix a few wayland issues (#815)
This PR fixes a few wayland issues of alacritty (and updates glutin on the process because it is needed). Mainly two changes are done: 1. Add a drawing_ready() method on Window: see https://docs.rs/winit/0.8.2/winit/os/unix/trait.WindowExt.html#tymethod.is_ready for explanations. Hopefully glutin will be able to handle it itself in the future, but it currently does not. 2. resize window and OpenGL contextes. The way wayland forces winit to draw its own decorations and how surface size is defined by its content means that in practice: - winit's window.set_inner_size() defines the dimensions of the borders - glutins gl_window.resize() defines the dimensions of the content (and is a noop in other platforms) It is for now glutin's user responsibility to keep them in sync otherwise borders are drawn stupidly. This PR changes the resize methods of alacritty::Window to always update both. This fixed the borders issues for me, tested on weston.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index fb31a1d7..baa52b94 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -33,7 +33,7 @@ clap = "2"
fnv = "1"
unicode-width = "0.1.4"
arraydeque = "0.2.3"
-glutin = "0.9.2"
+glutin = "0.10.0"
clippy = { version = "*", optional = true }