aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorJoe Wilm <joe@jwilm.com>2017-05-28 09:38:10 -0700
committerJoe Wilm <jwilm@users.noreply.github.com>2017-06-11 13:21:13 -0700
commit529ac47fc81f12e953568826b87ef75568eaa83b (patch)
tree450024deb1f8d4340142d46a11ae9749cf786b77 /Cargo.toml
parent9825adf695a472be5d3316354f707c7d9d2d2730 (diff)
downloadalacritty-529ac47fc81f12e953568826b87ef75568eaa83b.tar.gz
alacritty-529ac47fc81f12e953568826b87ef75568eaa83b.zip
Add support for Beam, Underline cursors
Notable about this implementation is it takes a different approach for managing cursor cells that previously. The terminal Grid is now borrowed *immutably*. Instead of mutating Cells in the Grid, a list is managed within the RenderableCellsIter. The cell at the cursor location is skipped over, and instead cells are popped off a list of cursor cells. It would be good in the future to share some more code between the different cursor style implementations for populating the cursor cells list. Supercedes #349.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml3
1 files changed, 2 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 0a2d8a1a..4709ea67 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -32,7 +32,7 @@ log = "0.3"
clap = "2.20"
fnv = "1.0.5"
unicode-width = "0.1.4"
-
+arraydeque = "0.2"
clippy = { version = "0.0.104", optional = true }
[target.'cfg(any(target_os = "linux", target_os = "freebsd", target_os="dragonfly", target_os="openbsd"))'.dependencies]
@@ -44,6 +44,7 @@ default = ["err-println"]
live-shader-reload = []
err-println = []
nightly = []
+bench = []
[build-dependencies]
gl_generator = "0.5"