diff options
author | Aaron Hill <aa1ronham@gmail.com> | 2017-09-27 20:29:44 -0400 |
---|---|---|
committer | Joe Wilm <jwilm@users.noreply.github.com> | 2017-09-27 17:29:44 -0700 |
commit | 5f7885749c4d7e48869b1fc0be4d430601cdbbfa (patch) | |
tree | 77916f2d24f71c846700139bbeaacec1f8699928 /Cargo.toml | |
parent | eb231b3e70b87875df4bdd1974d5e94704024d70 (diff) | |
download | alacritty-5f7885749c4d7e48869b1fc0be4d430601cdbbfa.tar.gz alacritty-5f7885749c4d7e48869b1fc0be4d430601cdbbfa.zip |
Use clippy = "*", update, and fix some warnings (#796)
Because there are so many clippy warnings in the current codebase,
this commit removes '#![cfg_attr(feature = "clippy", deny(clippy))]',
to make it easier to fix warnings incrementally.
Diffstat (limited to 'Cargo.toml')
-rw-r--r-- | Cargo.toml | 3 |
1 files changed, 2 insertions, 1 deletions
@@ -34,7 +34,8 @@ fnv = "1" unicode-width = "0.1.4" arraydeque = "0.2.3" glutin = "0.9.2" -clippy = { version = "0.0.155", optional = true } +clippy = { version = "*", optional = true } + [target.'cfg(any(target_os = "linux", target_os = "freebsd", target_os="dragonfly", target_os="openbsd"))'.dependencies] x11-dl = "2" |