aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorChristian Duerr <chrisduerr@users.noreply.github.com>2018-06-17 09:19:30 +0000
committerGitHub <noreply@github.com>2018-06-17 09:19:30 +0000
commit5ba34d4f9766a55a06ed5e3e44cc384af1b09f65 (patch)
tree11965fbe66f5d25ea00be1a02e74b724c4071d3c /Cargo.toml
parent0f700a01bd73623cdfc0afc4a54f9e82f46d8f49 (diff)
downloadalacritty-5ba34d4f9766a55a06ed5e3e44cc384af1b09f65.tar.gz
alacritty-5ba34d4f9766a55a06ed5e3e44cc384af1b09f65.zip
Move to cargo clippy
Using clippy as a library has been deprecated, instead the `cargo clippy` command should be used instead. To comply with this change clippy has been removed from the `Cargo.toml` and is now installed with cargo when building in CI. This has also lead to a few new clippy issues to show up, this includes everything in the `font` subdirectory. This has been fixed and `font` should now be covered by clippy CI too. This also upgrades all dependencies, as a result this fixes #1341 and this fixes #1344.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml1
1 files changed, 0 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 5c7f4f26..a316f4d7 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -34,7 +34,6 @@ fnv = "1"
unicode-width = "0.1"
arraydeque = "0.4"
glutin = "0.16"
-clippy = { version = "*", optional = true }
env_logger = "0.5"
base64 = "0.9.0"