aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorJoe Wilm <joe@jwilm.com>2016-10-27 08:43:23 -0700
committerJoe Wilm <joe@jwilm.com>2016-10-27 08:43:23 -0700
commite503baf2e753a1cc8c287f10fb1460635d093168 (patch)
treebe8ee683c384186060a14c72ee44609dd1d529bc /Cargo.toml
parentea07f03ac901c366ed31da540711b84ca9e75602 (diff)
downloadalacritty-e503baf2e753a1cc8c287f10fb1460635d093168.tar.gz
alacritty-e503baf2e753a1cc8c287f10fb1460635d093168.zip
Live shader reloading is now a feature
Which means it can be disabled in release builds. No more working on a renderer feature and actually breaking the Alacritty your editor is running inside.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml6
1 files changed, 5 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index f87a0cbe..d3132ddc 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -3,7 +3,6 @@ name = "alacritty"
version = "0.1.0"
authors = ["Joe Wilm <joe@jwilm.com>"]
license = "Apache-2.0"
-exclude = ["res/*"]
build = "build.rs"
[dependencies]
@@ -21,6 +20,11 @@ vte = "0.1.2"
mio = "0.6"
copypasta = { path = "./copypasta" }
+[features]
+default = []
+# Enabling this feature makes shaders automatically reload when changed
+live-shader-reload = []
+
[build-dependencies]
gl_generator = "0.5"