aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorgolem131 <golem131@users.noreply.github.com>2018-01-26 23:20:42 +0300
committerChristian Duerr <chrisduerr@users.noreply.github.com>2018-01-26 20:20:42 +0000
commitb82622e9948d1c90fc628739c7f328816214fb33 (patch)
tree4b0d306460c302258953f758c19cba60bad2ee06 /Cargo.toml
parent59b561b440060e7b0d13160fb69519d127e6c687 (diff)
downloadalacritty-b82622e9948d1c90fc628739c7f328816214fb33.tar.gz
alacritty-b82622e9948d1c90fc628739c7f328816214fb33.zip
Update dependencies
Updated the version of some dependencies. This also changes to a new clippy version so clippy can work with the latest nightly compiler again. Some issues created by new lints have been fixed.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml8
1 files changed, 4 insertions, 4 deletions
diff --git a/Cargo.toml b/Cargo.toml
index eee109d8..e29eb881 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -13,7 +13,7 @@ name = "alacritty"
[dependencies]
libc = "0.2"
-cgmath = "0.15"
+cgmath = "0.16"
notify = "4"
bitflags = "1"
font = { path = "./font" }
@@ -28,14 +28,14 @@ mio = "0.6"
mio-more = "0.1"
copypasta = { path = "./copypasta" }
xdg = "2"
-log = "0.3"
+log = "0.4"
clap = "2"
fnv = "1"
unicode-width = "0.1"
arraydeque = "0.2"
glutin = "0.12"
clippy = { version = "*", optional = true }
-env_logger = "0.4"
+env_logger = "0.5"
base64 = "0.9.0"
[target.'cfg(any(target_os = "linux", target_os = "freebsd", target_os="dragonfly", target_os="openbsd"))'.dependencies]
@@ -52,7 +52,7 @@ nightly = []
bench = []
[build-dependencies]
-gl_generator = "0.7"
+gl_generator = "0.8"
[profile.release]
lto = true