diff options
author | Joe Wilm <joe@jwilm.com> | 2017-04-26 10:26:46 -0700 |
---|---|---|
committer | Joe Wilm <jwilm@users.noreply.github.com> | 2017-05-01 08:36:09 -0700 |
commit | 574586045f08307b310983ed713972d0b6a45c30 (patch) | |
tree | 0419c4d54ca292c06e6411979a40e8a26e029ca7 /Cargo.toml | |
parent | 09031decc0510c107804aea490e437176bbb3535 (diff) | |
download | alacritty-574586045f08307b310983ed713972d0b6a45c30.tar.gz alacritty-574586045f08307b310983ed713972d0b6a45c30.zip |
Support setting _NET_WM_PID in X11 environments
Support is added for setting _NET_WM_PID automatically. This is to
support scripting of the window environment. For example, this makes it
possible to script opening a window with same CWD:
1. Retrieve the current window
2. (new) get PID of window
3. Check if it's Alacritty, find first child (presumably a shell), and
get the child's cwd.
4. Spawn new instance of terminal with cwd.
Unaddressed in this commit is how this will coexist on a Wayland system.
Diffstat (limited to 'Cargo.toml')
-rw-r--r-- | Cargo.toml | 3 |
1 files changed, 3 insertions, 0 deletions
@@ -35,6 +35,9 @@ unicode-width = "0.1.4" clippy = { version = "0.0.104", optional = true } +[target.'cfg(any(target_os = "linux", target_os = "freebsd", target_os="dragonfly", target_os="openbsd"))'.dependencies] +x11-dl = "2.12.0" + [features] default = ["err-println"] # Enabling this feature makes shaders automatically reload when changed |