aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorJoe Wilm <joe@jwilm.com>2016-02-21 15:20:03 -0800
committerJoe Wilm <joe@jwilm.com>2016-02-21 15:20:03 -0800
commit2a7dc1deb825f9f1db6de8b50656ef420ff41a44 (patch)
treee7206c9a4187232bccee88ee7cfa5e1d14ecbad4 /Cargo.toml
parent621776cd94890936b24f3abb8b7ec1f36dad9150 (diff)
downloadalacritty-2a7dc1deb825f9f1db6de8b50656ef420ff41a44.tar.gz
alacritty-2a7dc1deb825f9f1db6de8b50656ef420ff41a44.zip
Add function for listing font names on linux
This function isn't exactly useful, but it's working ffi with the fontconfig library. Woo! Next step will be returning some objects with more information (like font path so we can start rendering glyphs!).
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml3
1 files changed, 3 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index e970b9ea..d2aa21e5 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -4,3 +4,6 @@ version = "0.1.0"
authors = ["Joe Wilm <joe@jwilm.com>"]
[dependencies]
+servo-fontconfig = "0.2"
+freetype = { git = "https://github.com/servo/rust-freetype.git" }
+libc = "*"