aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorJoe Wilm <joe@jwilm.com>2016-09-24 16:11:50 -0700
committerJoe Wilm <joe@jwilm.com>2016-09-24 17:03:07 -0700
commitf1499d1d4518674c6c3c5c859a7028709bdd741d (patch)
tree4500d7a560b01d33b3da02e44c90ca7b0385158d /Cargo.toml
parentbe09467d48a5b7644411c2a09d948ee89509894e (diff)
downloadalacritty-f1499d1d4518674c6c3c5c859a7028709bdd741d.tar.gz
alacritty-f1499d1d4518674c6c3c5c859a7028709bdd741d.zip
Use evented I/O for the pty
This was largely an experiment to see whether writing and reading from a separate thread was causing terminal state corruption as described in https://github.com/jwilm/alacritty/issues/9. Although this doesn't seem to fix that particular issue. Keeping this because it generally seems more correct than reading/writing from separate locations.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index a8067ccb..56a5b71b 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -18,6 +18,7 @@ serde = "0.8"
serde_yaml = "0.4"
serde_macros = "0.8"
vte = "0.1.2"
+mio = "0.6"
[build-dependencies]
gl_generator = "0.5"