aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorJoe Wilm <joe@jwilm.com>2016-09-18 11:17:44 -0700
committerJoe Wilm <joe@jwilm.com>2016-09-18 11:26:00 -0700
commit13d2d66b6bf213726ec864b84db471f2eec9f742 (patch)
tree4b2b1bbe9173bfd250d5b840e5e85dc76c9ad424 /Cargo.toml
parent0d6d0dc0af028ead15c188db5d5f30e39fe0e3e7 (diff)
downloadalacritty-13d2d66b6bf213726ec864b84db471f2eec9f742.tar.gz
alacritty-13d2d66b6bf213726ec864b84db471f2eec9f742.zip
Rewrite ansi parser using vte crate
Using the vte crate allows removal of the ansi parser state machine and enables us to just be concerned with actions described in the protocol. In addition to making alacritty simpler, this also improves correctness and performance.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 9e8f8b81..f698ccb1 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -17,6 +17,7 @@ parking_lot = { version = "0.3.1", features = ["nightly"] }
serde = "0.8"
serde_yaml = "0.4"
serde_macros = "0.8"
+vte = "0.1.1"
[build-dependencies]
gl_generator = "0.5"