summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorJoe Wilm <joe@jwilm.com>2016-06-04 10:54:33 -0700
committerJoe Wilm <joe@jwilm.com>2016-06-04 10:54:33 -0700
commitf944b517fa8bea6eae62eb25fbabe1308d16ed55 (patch)
tree1173b311bf861aba8eb31eeb3ef4c35f17469f0f /Cargo.toml
parentc475c82c69d5d255d6236ad3b2cb6dffe2ed2e8b (diff)
downloadalacritty-f944b517fa8bea6eae62eb25fbabe1308d16ed55.tar.gz
alacritty-f944b517fa8bea6eae62eb25fbabe1308d16ed55.zip
Add live-reload for shaders
Recompiling the entire program whenever a shader changes is slow, and it can interrupt flow. Shader reloads are essentially instantaneous now. If the new shader fails to compile, no state is changed; the previous program continues to be used.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index ef2cdf32..de8c09cc 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -12,6 +12,7 @@ freetype-rs = "0.9.0"
libc = "*"
cgmath = "0.7"
euclid = "0.6"
+notify = { git = "https://github.com/jwilm/rsnotify", branch = "add-ignore-op" }
[build-dependencies]
gl_generator = "0.5"