summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorJoe Wilm <joe@jwilm.com>2017-02-01 09:55:23 -0800
committerJoe Wilm <jwilm@users.noreply.github.com>2017-02-02 09:07:00 -0800
commit40d7c0c4344022636f27fac89c4253140b8019fc (patch)
tree61daec0d09116ce54afe7c5c5742f9ce5c550d04 /Cargo.toml
parentb27d1266d6d28912012dfb4e236a3ade4fd1c74a (diff)
downloadalacritty-40d7c0c4344022636f27fac89c4253140b8019fc.tar.gz
alacritty-40d7c0c4344022636f27fac89c4253140b8019fc.zip
Implement save/restore cursor position
This passes the vttest for save and restore cursor position. The implementation was done according to: http://www.vt100.net/docs/vt510-rm/DECSC.html As of yet, there are a few things not supported by the terminal which should otherwise be saved/restored. vte was updated for a fix with CSI param parsing
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index b93206c2..f7bbb161 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -27,7 +27,7 @@ parking_lot = { version = "0.3.1", features = ["nightly"] }
serde = "0.9"
serde_yaml = "0.6"
serde_derive = "0.9"
-vte = "0.2.1"
+vte = "0.2.2"
mio = "0.6"
serde_json = "0.9"
copypasta = { path = "./copypasta" }