aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml34
1 files changed, 34 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 00000000..996816d3
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,34 @@
+# SPDX-License-Identifier: MIT
+# Copyright (c) 2023 Robin Jarry
+
+[package]
+name = "aerc"
+version = "0.20.0"
+edition = "2021"
+authors = ["Robin Jarry <robin@jarry.cc>"]
+description = "A pretty good email client"
+readme = "README.md"
+homepage = "https://aerc-mail.org/"
+repository = "https://git.sr.ht/~rjarry/aerc"
+license = "MIT"
+
+[dependencies]
+anyhow = { version = "1.0.69", features = ["backtrace"] }
+bitflags = "1.3.2"
+clap = { version = "4.1.4", features = ["derive", "env"] }
+configparser = { version = "3.0.2", features = ["indexmap"] }
+crossterm = { version = "0.25.0", features = ["event-stream"] }
+derivative = "2.2.0"
+futures = "0.3.26"
+gtmpl = "0.7.1"
+log = "0.4.17"
+simple_logger = { version = "4.0.0", default-features = false, features = ["time", "timestamps"] }
+time = "0.3.17"
+tokio = { version = "1.25.0", features = ["full"] }
+tui = "0.19.0"
+
+[profile.release]
+lto = true
+codegen-units = 1
+strip = true
+debug-assertions = false