summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2007-12-23 18:27:47 +0000
committerNick Mathewson <nickm@torproject.org>2007-12-23 18:27:47 +0000
commit473725e1a47c65b59dc22d974c0d7dd2d7f7c44c (patch)
treed87a0111be162564e575f9c64d02b0795920959b /configure.in
parent4606a8af03983b6a08e9fc05d49c710922242f3e (diff)
downloadtor-473725e1a47c65b59dc22d974c0d7dd2d7f7c44c.tar.gz
tor-473725e1a47c65b59dc22d974c0d7dd2d7f7c44c.zip
r15648@tombo: nickm | 2007-12-23 13:27:30 -0500
Support building for iPhone; patch from cjacker huang. svn:r12946
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 3645d77d14..8e3765c81c 100644
--- a/configure.in
+++ b/configure.in
@@ -25,6 +25,15 @@ AC_ARG_ENABLE(debug,
CFLAGS="$CFLAGS -g"
fi])
+#XXXX ideally, we should make this into a no-op, and detect whether we're
+#compiling for the iphone by using $target.
+AC_ARG_ENABLE(iphone,
+ AS_HELP_STRING(--enable-iphone, compile with iPhone support),
+ [if test x$enableval = xyes ; then
+ tor_cv_iphone=true
+ CFLAGS="$CFLAGS -D__DARWIN_UINX03 -DIPHONE"
+ fi])
+
AC_ARG_ENABLE(cell-pool,
AS_HELP_STRING(--disable-cell-pool, disable pool allocator for cells))